Ubuntu amd64 安装 Adobe AIR

安装Adobe AIR起源于twitter。虽然twitter跟饭否不能访问以来,基本上断了这个念想,因为新浪围脖又开始起来,加上在手机论坛上见到不少玩twitter的,就动了这个念想。一玩,还真觉得很有意思。

聊起来就觉得这东西实的是不错。就象生活中有一些散碎的银子,虽然我们都没有注意到,但是在twitter上如同流水一样哗啦啦流过,还真是透出一丝清凉。凉啊凉,凉就凉出了~~~

网上有很少twitter的客户端,结合一些可用的api provider就可以玩这个小东西了。比如Mixero。Mixero是个基于Adobe AIR的客户端。为了这个,我需要在Ubuntu 9.10 amd64上安装一下Adobe AIR。直接安装完是不能用的,因为AIR调用了一些32位的lib。具体过程可以参考:INSTALL AIR 1.5 ON 64-BIT UBUNTU 7.10, 8.04 AND 9.04:

第一步:到http://get.adobe.com/air/下载AIR的安装包AdobeAIRInstaller.bin。
第二步 下载getlibs。这个工具主要用来安装AIR运行中所需要的32-bit lib。
第三步 获得安装程序需要的库。
$ sudo getlibs ./AdobeAIRInstaller.bin
$ sudo getlibs -l libgnome-keyring.so
$ sudo getlibs -l libgnome-keyring.so.0
$ sudo getlibs -l libgnome-keyring.so.0.1.1
第四步 运行安装程序
$ ./AdobeAIRIntaller.bin
现在Adobe AIR已经可以使用了。

注意,因为我在之前安装过32位的库,所以在Adobe官方文章中所到的一些库文件不需要重新安装。

打赏

《Ubuntu amd64 安装 Adobe AIR》有2个想法

  1. [code language=”bash”]
    $ sudo getlibs -l libgnome-keyring.so
    $ sudo getlibs -l libgnome-keyring.so.0
    $ sudo getlibs -l libgnome-keyring.so.0.1.1
    [/code]
    这几步切切不可忘了,因为有一些需要https的好象需要它。

  2. Mixero客户端从目前比较来看是比较优秀的。可以跨平台,而且支持自定义API。比起我现在用的需要VPN支持的TweetDeck来说使用难度小了不少。

发表评论

电子邮件地址不会被公开。 必填项已用*标注