解读,Yupoo使用的软件

今早发现有人推荐了这个,Yupoo使用的软件,对成熟解决方案的学习一直是我的一个爱好。做为国内图片托管的历史比较长的公司,虽然我从来没有使用过,但是名声还是经常耳闻的。

TAG云中果然好多软件!壮观:

Apache AWStats bottle CentOS Cacti cURL Debian Erlang Firebug google-perftools gevent Hadoop Heartbeat ImageMagick IPVS imagick ibrowse Java lighttpd Lua libmemcached libevent MySQL mochiweb Memcached MySQLdb Mogilefs Mercurial Mootools MacOSX Nginx Nagios NTP Net-SNMP OpenVPN PHP Python Predis php-amqp pylibmc php-memcached Postfix Redis Riak RabbitMQ Redmine Readline Solr Squid Twisted Ubuntu VIM vsftpd XCache Xdebug

继续阅读解读,Yupoo使用的软件

Django使用frameset

前兩天想用Django的時候,因為手頭這個東西是用到frame,於是有點悲哀了。後來看到這個已經解決的文章,發現自己變蠢的時間最近多了。
將各frame的src映射即可了。。。

Django的幾篇而意義的探討:
1. 混合使用django模板和jinja模板
2. 偶对django的rant
3. 初识django, 一起进入python的世界吧
4.

Ubuntu 10.04安裝gnochm

早早升級了10.04,一切都很好,除了wacom現的還不好用(9.10已經好用了,但升級之後不行。9.10也是全新安裝的好。)。

昨天安裝gnochm出現問題,提示說:
[code language=”bash”]
The following packages have unmet dependencies:
gnochm: Depends: python-gtkhtml2 which is a virtual package.
[/code]

launchpad很顯示這個不算是bug,是因為python-gtkhtml2模塊被移除了。根據v1nsai的提示,下載deb文件安裝解決。
下載位置:http://packages.debian.org/sid/python-gtkhtml2
賺選擇鏡像站點麻煩可以直接點擊:
ftp下載點
http下載點

參見:
Please remove python-gtkhtml2 from package dependencies

两个开源的短址实现

前一段时间在研究短址服务,以下两个是非常不错的:
1. python-bitly
A python wrapper around the bit.ly API
2. yourls
YOURLS is a set of PHP script that will allow you to run your own URL shortener, a la TinyURL/bit.ly
You can make it private or public, and a WordPress plugin makes integration with your WordPress blog (and Twitter) a snap. It provides wicked stats and analytics. There’s an API. It’s free.

yourls比我现在在http://1ux.cn/上面用的那个好。