奇怪的问题

话说上一篇文章安装了python2.5、python2.6、python3.0的方法。没过5分钟就出了问题。起因是我设置了python2.5为缺省的python,当我安装compiz的时候就出问题了。
[code language=”bash”]
ValueError: /usr/bin/python does not match the python default version. It must be reset to point to python2.6
[/code]

我想问题可能是出在2.5上了,于是切换

[code language=”bash”]
sudo update-alternatives –config python
[/code]
选择2.6,結果出乎意料,上面的问题仍然出现。

不过测试/usr/bin/python –version,显示是2.6啊。

实在想不到,最后的解决办法居然是:
[code language=”bash”]
sudo rm /usr/bin/python && sudo ln -s python /usr/bin/python
[/code]

真是个奇怪的问题。

参考文章:
1. apt-get upgrade -> python does not match the python default version

发表评论

电子邮件地址不会被公开。 必填项已用*标注