How to use gwt on Ubuntu amd64?

准备测试gwt,选错了环境,使用了amd64版本的Linux,结果是自然的。
32bit-lib-needed

Environment:
Linux Mint 7(Based on Ubuntu 9.04) amd64
Eclipse 3.5
gwt linux 1.7.1

1. Install JDK 32-bit version
Download the setup file from java.sun.com like: jdk-6u16-linux-i586.bin
$chmod +x jdk-6u16-linux-i586.bin
$sudo ./jdk-6u16-linux-i586.bin
$sudo mv jdk1.6.0_16/ /usr/lib/jvm/

2. Use desired 32-bit jre library in Eclipse project
Screenshot-Edit Library
manually add: tools.jar

3. Install 32bit gtk support
$sudo apt-get install ia32-libs

4. You will get this:
Screenshot-Google Web Toolkit Hosted Mode
Screenshot-Web Application Starter Project

参考:http://blog.foofactory.fi/2008_10_01_archive.html
让gwt在linux 64位机上跑起来
tools.jar not present in ia32-java-6-sun

打赏

发表评论

电子邮件地址不会被公开。 必填项已用*标注